Ellucian Cloud & Banner PROD Slowness Being Reported
Incident Report for ASU System ITS Status
Update
We are continuing to investigate this issue.
Posted Nov 12, 2024 - 15:06 CST
Investigating
Ellucian Cloud has been notified about slowness affecting users in production.
Posted Aug 14, 2024 - 08:30 CDT
This incident affects: Administrative Services (Banner AppNav) and Banner SelfService 9.