Arkansas State University System

ITS System Status

Real-time availability, maintenance notices, and incident updates for university technology services.

Residential Hall Wi-Fi Authentication Issues

Incident Report for ASU System ITS Status

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 07:55 CDT

Investigating

We are currently investigating this issue.
Posted Jun 25, 2026 - 15:58 CDT
This incident affected: Campus Network (Wireless).