Arkansas State University System

ITS System Status

Real-time availability, maintenance notices, and incident updates for university technology services.

University Email Issues

Incident Report for ASU System ITS Status

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 14:07 CDT

Investigating

We are currently investigating issues around email with Office 365.
Posted Aug 14, 2026 - 09:01 CDT
This incident affected: Collaboration Tools (Outlook 365).