Canvas Down

Incident Report for ASU System ITS Status

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 21:37 CDT

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 15:26 CDT

Investigating

About This Incident
We are currently investigating an outage affecting Canvas access for users at our university.

What to Expect
During this time, users may be unable to access Canvas or may experience issues loading courses, assignments, grades, or other Canvas features. Our team is actively working to identify the cause of the issue and determine the fastest path to restoration.

What We’re Doing
ITS is monitoring the situation and reviewing available system information to determine whether the issue is related to Canvas, campus systems, authentication, networking, or another connected service.

Next Update
We will provide additional information as soon as we have confirmed details or a meaningful update to share.

Thank you for your patience while we investigate and work toward restoring normal access.
Posted May 07, 2026 - 15:25 CDT
This incident affects: Teaching & Learning Tools (Canvas LMS).