Arkansas State University System

ITS System Status

Real-time availability, maintenance notices, and incident updates for university technology services.

Reports of Wifi Issues in Academic Areas

Incident Report for ASU System ITS Status

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 18:18 CDT

Investigating

We are currently investigating reports of Wifi issues within academic areas at NYIT
Posted Aug 06, 2026 - 09:45 CDT
This incident affected: Campus Network (Wireless).